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Power Process Controller
Introduction

 
 
Introduction

 
Power Process controller is an essential tool for dealing with threatening programs. It 
lists all the processes active on your computer, displays information on the process 
details and allows you to kill programs manually if necessary. Several other tools offer 
you detailed information about Internet connections, DLL files, CPU and memory use, 
Internet server programs running on your computer.

You will get information and also change them. It meets all your needs for monitoring 
processes. Try it now!

 
 

Page 3



Power Process Controller
Features

Features Overview 
 

What the Power Process Controller is and what you can do with it: 
 

●     See what's happening behind the desktop. 

●     See the modules of each running process, Power Process Controller allows you 
to close normally or terminate any running process.

●     See graphs and data on CPU and memory usage.

●     Complete information about processes and modules.

●     Show the general information. 

●     Specify process counter column headings. 

●     Black List which confirms that items being analyzed are not acceptable. 

●     White List which confirms that the item being analyzed is acceptable.

●     Search for process information through Google. 

●     Pause process suspends the execution of process until it is reactivated by the 
resume process command. 

 
 
 
 
So, with one quick look you can see that Power Process Controller is the tool 
you've been looking for to show you the inner workings of your computer, manually 
control program processes and more. 
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Power Process Controller
The user interface (Overview)

The user interface (Overview) 

 
 

 
 
 
 

Overview: When Power Process Controller is started, all currently running processes are 
displayed under the Processes tab. 
 
Toolbar: Adding new applications, regulating update speed, select columns for processes 
and help content are all included to help users run these relevant commands 
conveniently.  
 
Task Panel: Allows user to approve or deny some of the commonly used tasks.

Tab Page: Applications, Processes, Performance, Black List, and White List allow user to 
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navigate from one page to another
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Power Process Controller
Using Process of Toolbar

How to Add a new application

Add a new application by clicking  

 
The following steps describe how to add a new application: 
 

Step1: Click the "New Application" button to open the Windows Run dialog. 
 

Step2: Type the name of a program, folder, document or internet resource, and 
windows will open it for you. in  

 

About Update Speed

This function allows you to choose the frequency at which the data is automatically 

updated, Click  menu, then click the desired command. To 

temporarily freeze the data displayed in Power Process Controller, Click "Paused" in 
the same menu. Data is automatically updated every one second by default.

How to select columns

The following steps describe how to select columns: 
 

Step1:Click the "Processes"  tab. 
 

Step2:Cick the button , and the following dialog will appear:  
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Select the columns that you are about to add on the process page of the process 
manager, click OK to confirm or Cancel to cancel. 

 
 
Other Using Process:

Using Process of Application

Using Processes

Using Process of Performance

Using Process of Black List

Using Process of White List
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Power Process Controller
Using Process of Applications

Using Process of Applications

Step 1: Click "Applications" Page, Power Process Controller displays all active programs 
on the taskbar. 

 

Step 2: To perform a task with a running program, right click the program and select a 
desired action from the list or select the action form the task panel.  
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To switch to another program, click desired program and click "Switch To".

To bring a program to front, click desired program and click "Bring To Front".

To control the program's window, right click the desired program and select "Minimize" 
or "Maximize". 

 
To end a program, click the desired program and click "End Task" in the task panel. 

WARNING: Any data entered or changes made without being saved in selected 
program will be lost.

 
 To go to the process interface, click the desired program and click "Go To Process" in 

the task panel. 
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Other Using Process:

Using Process of Toolbar

Using Processes 

Using Process of Performance

Using Process of Black List

Using Process of White List
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Power Process Controller
Using Processes

Using Processes

 
 
Power Process Controller allows you to view detailed processes information (with 
descriptions), stop and start new processes, set priorities and much more. You can easily 
find and remove unnecessary background processes.

You can easily see what's happening behind the desktop which processes are running on 
your computer. 

On the Processes interface, click a listed process to view the General information about 
the process. Click Show Tips under the View menu to hide the displayed information. The 
following steps will assist in viewing the detailed information of listed processes.  

 

Page 12



 
 

Step 1 

To end a process, right click the desired process to end and click "End Process". 

WARNING: Terminating a process can cause undesired results including loss of data 
and system instability. The process will not be given the chance to save its state or data 
before it is terminated. 

To end a process tree, right click the desired process to end and click "End Process Tree" 

 WARNING: This operation will attempt to terminate this process and any processes 
which were directly or indirectly started by it. Forcing processes to terminate in this 
manner can cause data loss and system instability.

Step 2

A. To debug the selected program by clicking the "Debug". 

WARNING: This operation may result in loss of data.

B. Pause process suspends the execution of process until it is reactivated by the resume 
process command, click the "Pause" or "Resume". 

WARNING: This operation will attempt to pause this process. If you pause some 
system process, it can cause system instability

C. Resume the paused process by clicking "Resume".
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D. Delete the process by clicking the "Delete". 

WARNING: Delete a process can cause undesired results including loss of data and 
system instability. It will delete the execute file of this process. 

Step 3:  
 
Click " Show Details" to show information, used modules and used threads about the 
process. (Same operation available in the Action area) 
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A: To unload module of a process. 
On the Modules Used tab, click the module that you want to unload, and then right-click 
to Unload Module  
 
B: To delete module of a process 
On the Modules Used tab, click the module that you want to delete, and then right-click 
to Delete Module. 
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WARNING: The two operations may cause the process crash and if you unload or 
delete module of some system process, it can cause system instability.

C: To open properties of a process module 
 
Click "Open Properties", the properties of the selected module will be displayed. 
 
D: To open folder for a process module 
 
Select a process module and right click "Open Folder" for detailed information.

E: Free online resources are available for module information through Google, by clicking 
"Google Process".

Note: You are able to search the online resource, open properties and folder for the 
selected process in the Action part. 
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Step 4: You can end or Pause thread suspends the execution of process until it is 
reactivated by the resume thread command, like this dialog: 

WARNING: This operation will attempt to end the thread of this process, it may cause 
the process break down and instability. 

 

Other Using Process: 

Using Process of Toolbar

Using Process of Application Page 17



Using Process of Performance

Using Process of Black List

Using Process of White List
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Power Process Controller
Using Process of Performance

Using Process of Performance

The Memory and CPU performance data is displayed on this page, including physical and 
virtual memory, and CPU usage. The data refreshes at the same interval that the main 
display does. The Performance tab provides detailed information on the current status of 
your system. You can view the current processor usage in percent, and a graph of the 
processor usage for the last several seconds. A similar graph also shows memory usage 
for the last several seconds. You can also view the current usage of the paging file and 
the physical memory on kilobytes.  
 

Click "Performance" Tab to view the performance graphs displaying memory and CPU 
performance data, including physical and virtual memory and CPU usage. 
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Other Using Process:

Using Process of Toolbar

Using Process of Application

Using Processes

Using Process of Black List

Using Process of White List
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Power Process Controller
Using Process of Black List

Using Process of Black List

Power Process Controller offers the feature of "Black List" which is the list of processes 
that will be terminated in your system. Black List will terminate unwanted or threatening 
processes immediately when listed here. To terminate processes, add unwanted 
processes to Black List. 
The following steps describe how to kill processes on Black List. 
 

Step 1: Click the "Black List" Tab. 

Step 2: Type the name of the process and click  or "Add To List" in the task 
panel to add a process to the Black List.  

Step 3: Click "Delete From List" to delete the selected program from the Black List.

Step 4: Click "Auto Kill" to terminate all processes listed in the Black List.
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Warning: This operation will attempt to terminate listed processes. The process will 
not be given the chance to save its status or data before it is terminated. 

 
Other Using Process:

Using Process of Toolbar

Using Process of Application

Using Processes

Using Process of Performance

Using Process of White List
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Power Process Controller
Using Process of White List

Using Process of White List

White List confirms acceptable processes. It is a list of process names allowed to run on 
your computer. 

Add all allowed or safe processes to White List. Power Process Controller will terminate all 
unlisted processes when you click "Auto Kill". 

step 1: Type the process name you want to add ,then click  or the "Add To List".

step 2: To remove a process from the list, click "Delete From List".

step 3:Click "Auto Kill" to terminate all unlisted processes. 
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Warning: This operation will attempt to terminate all unlisted processes. The unlisted 
process will not be given the chance to save its state or data after you click "Auto kill"

 
Other Using Process:

Using Process of Toolbar

Using Process of Application

Using Processes

Using Process of Performance

Using Process of Black List

 

Page 24

http://www.pcgasstation.com/power_process_controller/purchase.htm


Power Process Controller
Question Icon

Question Icon

The button  shows other information about Power Process Controller. 
Click this icon to see the window below: 

 
Help Content: Guides you to a detailed help page about Power Process Controller.  
Enter Key: Enter the registration key to replace the trial version with full version.  
Online Resources: Guides you to PCGasStation Website .  
Contact Technical Support: Contact our Support Team.  
About: Displays the information of this software.  
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Power Process Controller
About PCGasStation

About PCGasStation

Be the Global Leader of Windows!  
 
 
Being a shareware developer of Windows Operating System solutions, 
PCGasStation take the lead in this domain. We have professional experience in 
execute our faith - Think as A Customer. This has given us the idea to create 
reliable and easy-to-use software.  
 
With sleek, clear interfaces, PCGasStation R&D Center creates simple solutions to 
complicated problems.  
 
Contact Us 
 
For Customers 
Email: 
English: support@pcgasstation.com 
French: support_fr@pcgasstation.com 
German: support_de@pcgasstation.com 
 
Power Process Controller 
Product ID: 300171546 

 
We always do our best to answer your question! 
 
For Partners 
North America: 
sales@pcgasstation.com 
We benefit together with our partners in a win-win model - the PCGasStation 
Business Model, and we love to talk about creating with you. 
 

 
 
http//www.pcgasstation.com 
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Power Process Controller
FAQs

FAQs

Replacing Task Manager  
 
If you click File > Replace Task Manager, Power Process Controller integrates itself 
into your system so that you can access the module by pressing Ctrl+Alt+Del, or by 
right clicking on an empty part of the taskbar and selecting Task Manager. If you 
want to use the Task Manager again, simply select the same menu item to remove 
the check mark in front of it. 
Note: This function is only available for Windows 2000 and Windows XP.  
 

Menu bar functions 
 
The menu bar at the top of the Power Process Controller window provides you with 
additional functions.  
 
Click File > New Application (Run...) to open the Windows Run dialog, which you can 
use to start a new application or open a file.  

Click Option > Select Columns ,On this page you can specify which columns 
(information) you want to see in the list view of Process Info. 

Click View > Always On Top, the process you choose always display on the most 
preceding.

Click Shut Down > Turn off, you can close your computer or restart it.

Click Help > Help content , show more help information in using of Power Process 
Controller. 
 

To end a process  
 
Click the process that you want to end, and then click End Process. 

 Be careful when ending a process. If you end an application, you will lose 
unsaved data. If you end a system service, some part of the system might not 
function properly. 

 Process Properties

The "Process Properties" dialog displays additional information about a process.

The following info is shown:

A: Complete version resource Page 27



B: Path of the process executable 

C: Current working directory 

D: Environment variables

E: Resource types 

F: Common file information
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Power Process Controller
How to buy Power Process Controller

How to buy Power Process Controller

As soon as you make your order, our resellers will verify it. Your order will most 
likely be processed within less than 1 hour, but in some VERY rare cases it may 
take resellers more than 24 hours to process your payment.  
 
The registration key will be automatically generated at our server and e-mailed to 
you immediately after we receive payment confirmation from our e-commerce 
reseller.  
 
Please do not worry if you haven't received the registration information right away. 
Delays usually occur due to the high security settings of spam filters used by our 
clients. Our message may be rejected as a spam message by the mail service you 
use.  
 
If you haven't got the registration message within several hours, feel free to 
contact our Support Teamvia email.  
 
If you have questions concerning our software, send e-mail to: 
support@pcgasstation.com. We always do our best to help you!

Why Power Process Controller?

Save Time 
a. It is outstanding in speed.
b. The easy-to-use interface helps you to catch on to the system quickly.
 

 
Save Money

a. It is your one-way ticket to monitoring all your processes.
b. 30-day money-back guarantee if you are not satisfied with it! 

 
All in one tool 

Do more with dealing with threatening programs, show more details about 
the process and kill programs manually are all supported by this powerful 
tool. 

 
Easy-to-use 

With step-by-step manual, Whether you are an experienced user or a 
beginner, the software will make the task of monitor your system a breeze! 
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What you will have after purchasing this product:

Full version of Power Process Controller 
Fun in unlimited system optimizing. 

 
Free update (Major Update Not Included) 
 
Customer care 

We are pleased to offer our care to meet your needs. We promise that any 
customer questions will be replied within 1 business day! 

 
Coupons for PCGasStation products in Discount Center 

We prepared a series of benefits to our customers.
 

Is my order secure?

We promise the most secure purchase as we did for years. 
All these PCGasStation partners-ShareIt and RegNow have passed strict 
certification. We truly believe in 'Only by benefiting our customer can we benefit 
ourselves'. So your purchase security in PCGasStation is our top priority! 
PCGasStation has been involved in E-commerce for years. And through these years, 
we built up a secure online shopping system. You can enjoy the speed and 
convenience we offer. 
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